Finally got myself a Fiesta ST

General Fiesta ST Discussion

Moderator: Fiesta ST Moderators

+
Posts: 647
Joined: Sun Oct 22, 2006 9:23 am
Location: Hiding somewhere in Cape Town
Make: Ford
Model: Fiesta
Type: ST
Year: 2014

Finally got myself a Fiesta ST

Postby TS.170 » Thu Feb 01, 2018 7:00 pm

Finally got a good 2014 model with 40 000km on the clock. I fitted the intake system which i still had from the Focus St and it works fine but after a week the engine light has com on. No limp mode or anything. Car pulls strong and drives beautifully but I cant get the engine light to switch off even after disconnecting the battery for 2 hours. Any idea how I could cancell the light before going to Ford to clear the code. I do plan on doing the Stealth software in a month or so. Thanx
Molten orange 2014 Fiesta ST
2010 Honda VFR1200 f
Ex 2010 Fiesta Titanium 1.6
Ex Focus ST 225
Ex Focus ST 170

+
User avatar
Posts: 8219
Joined: Thu Jul 06, 2006 11:03 am
Location: East Rand
Make: 1L Ford
Model: 2L Ford
Type: 3L Ford
Year: 1990

Re: Finally got myself a Fiesta ST

Postby V6 Capri » Fri Feb 02, 2018 9:52 am

You need to get it scanned to get the code and see what the code refers to.
Beste resep in die wereld! 1L Ford, 2L Ford & 3L Ford!!
Image+Image+Image

+
Posts: 647
Joined: Sun Oct 22, 2006 9:23 am
Location: Hiding somewhere in Cape Town
Make: Ford
Model: Fiesta
Type: ST
Year: 2014

Re: Finally got myself a Fiesta ST

Postby TS.170 » Fri Feb 02, 2018 7:12 pm

Strangely the light has gone off. But thanx v6 capri
Molten orange 2014 Fiesta ST
2010 Honda VFR1200 f
Ex 2010 Fiesta Titanium 1.6
Ex Focus ST 225
Ex Focus ST 170

Return to General Fiesta ST Discussion

Who is online

Users browsing this forum: No registered users and 1 guest