St150 seems a little sluggish.

Post any Technical questions, advice or problems here

Moderator: Fiesta ST Moderators

User avatar
Shaunp
+
Posts: 957
Joined: Tue Dec 18, 2012 11:44 am
Make: Ford
Model: Ford
Type: Ford
Year: 1992

Re: St150 seems a little sluggish.

Post by Shaunp » Wed Oct 19, 2016 4:54 pm

Does the car have traction control
Magic happens.

xaah4
-
-
Posts: 16
Joined: Mon Feb 22, 2016 1:43 pm
Make: ford
Model: fiesta
Type: xr4(st150!)
Year: 2007

Re: St150 seems a little sluggish.

Post by xaah4 » Wed Oct 19, 2016 10:35 pm

cheers stu. luckily theres no hills over here in oz,its all coastal! my confidence is restored.

User avatar
Stu
Site Moderator
Site Moderator
Posts: 41167
Joined: Fri May 05, 2006 3:50 pm
Make: Merc
Model: C63
Type: 507Edition
Year: 2013
Location: Kempton Park

Re: St150 seems a little sluggish.

Post by Stu » Mon Oct 24, 2016 9:59 am

xaah4 wrote:cheers stu. luckily theres no hills over here in oz,its all coastal! my confidence is restored.
:smt023
Polo20vBIGT
Kia Sportage
Rustler Bakkie
507 Edition C63 - The Dragon
Nissan GTR - The Ninja ( on Its way )
Image

FordCave
-
-
Posts: 4
Joined: Wed Mar 23, 2016 8:25 am
Make: Ford
Model: Fiesta
Type: ST150
Year: 2005

Re: St150 seems a little sluggish.

Post by FordCave » Sat Apr 08, 2017 6:45 pm

This is not your issue it would have shown on the dyno, but it is interesting. Now this is going to sound so ****, but I bought my ST 150 2005 model March 2016. I did a good service on the car. Replaced air filter, oil filter? Petrol filter and some good oil. I still had a power issue, so I got called out one evening and there was a hyundai I20 that pulled out inder me. I couldnt understand. Later that week I stopped at my house only to hear a hissing/sucking sound coming from the engine bay. I opened the air filter cover and looked a bit deeper to find a full size refuse bag chucked in deeply there.

Sent from my SM-N9005 using Tapatalk

FordCave
-
-
Posts: 4
Joined: Wed Mar 23, 2016 8:25 am
Make: Ford
Model: Fiesta
Type: ST150
Year: 2005

Re: St150 seems a little sluggish.

Post by FordCave » Sat Apr 08, 2017 6:47 pm

I hope your abs sensor solves it, as it makes sense. Or maybe there is something wrong with the drive shafts. As it shows that it has power from low down on the dyno.

Sent from my SM-N9005 using Tapatalk

KamNeva
-
-
Posts: 11
Joined: Sat Jul 27, 2019 1:34 am
Make: 3100
Model: Colt
Type: Estj
Year: 2017
Location: Panama
Contact:

St150 seems a little sluggish

Post by KamNeva » Tue Aug 13, 2019 7:05 pm

If i mount the drive manually

sudo mount /dev/sdk1 /mnt/disk22

This will work but it seems to take near a minute to mount the drive.

I think i need a way to get fstab to wait longer. I tried adding nofail but it still fails.

If you are you looking for more information regarding How much should my rent cost or Is tipping a thing in Bali take a look at our own internet site

Post Reply

Return to “General Fiesta ST Tech Talk”