No power Ford Bantam rocam 1.3i

Moderator: Other Ford Moderators

-
Posts: 10
Joined: Tue Oct 24, 2017 11:55 am
Location: Durbanville,Western Cape
Make: FORD
Model: BANTAM
Type: 1.3i XL
Year: 2007

No power Ford Bantam rocam 1.3i

Postby RookieRider » Sun Oct 29, 2017 9:12 am

Hi guys

My bakkie has no power under about 3000rpm then theres a huge increase in power after i rev pass 3000rpm.
Is this normal for the 1.3i?
It kinda feels like a janky VTEC in my bakkie :lol:

Site Moderator
User avatar
Posts: 41065
Joined: Fri May 05, 2006 3:50 pm
Location: Kempton Park
Make: Merc
Model: C63
Type: 507Edition
Year: 2013

Re: No power Ford Bantam rocam 1.3i

Postby Stu » Mon Oct 30, 2017 6:12 am

my 1300 bakkie has no power anywhere in the rev range :lol:
Polo20vBIGT
Kia Sportage
Rustler Bakkie
507 Edition C63 - The Dragon
Image

+
Posts: 5072
Joined: Mon Dec 05, 2011 11:17 am
Make: Mazda
Model: 2.0 Active
Type: 2.0 Active
Year: 2010

Re: No power Ford Bantam rocam 1.3i

Postby MrMazda » Mon Oct 30, 2017 7:35 am

Stu wrote:my 1300 bakkie has no power anywhere in the rev range :lol:


Stu I though you had a 160i? In any event its a die hard workhorse
Current: 2010 Mazda 6 Active, 2002 Bantam B3 1300, 2010 Sirion 1.3.
Ex:Mazda 323s X 5 1026 000km & 626s X 3 515 000km & B2200 D/c 4X4 345 000km & Meteor GLi 1.6i 120 000km, BMW 528i X2 44 000 km
Mazda 6 2006 Original 222 000km

-
Posts: 10
Joined: Tue Oct 24, 2017 11:55 am
Location: Durbanville,Western Cape
Make: FORD
Model: BANTAM
Type: 1.3i XL
Year: 2007

Re: No power Ford Bantam rocam 1.3i

Postby RookieRider » Mon Oct 30, 2017 1:07 pm

So im stuck with the janky vtec

Return to General Ford Tech Talk

Who is online

Users browsing this forum: No registered users and 1 guest