Fiesta Missfire when hot

Moderator: Other Ford Moderators

-
Posts: 2
Joined: Mon Dec 17, 2012 8:11 pm
Make: ford
Model: fiesta
Type: 1.4
Year: 2006

Fiesta Missfire when hot

Postby Ldoyle » Thu Jun 01, 2017 12:15 pm

Hi Guys

I think this is my first post on the forum. I have used the search function and could not find the answer, so here it goes.

my wife has a 2005 fiesta Duratec 1.4i. the car tends to misfire when hot. my immediate thought would be ignition coil. I’ve replaced the coil twice as I thought the new coil might be faulty as well. I've also replace the fuel pump. Replacement coils used are Lucas coils and fuel pump is Bosch. What else could it be?

Your assistance and advice would be highly appreciated.

+
User avatar
Posts: 2307
Joined: Fri Feb 25, 2011 6:44 pm
Make: Ford
Model: Focus
Type: ST250
Year: 2013

Re: Fiesta Missfire when hot

Postby German » Thu Jun 01, 2017 7:53 pm

**** question but are you running the correct spark plug heat range?
When does it happen, light and high load?

Sent from my ONE A2005 using Tapatalk
ST!!! All the Way !!ST

Ingot Silver Focus ST250
Mods:
Wouldn't you like to know?

http://www.karter.co.za/

-
User avatar
Posts: 23
Joined: Mon Apr 22, 2013 9:08 pm
Location: JHB
Make: Ford
Model: Focus
Type: ST
Year: 2007

Re: Fiesta Missfire when hot

Postby timb » Fri Jun 02, 2017 4:08 pm

My girlfriend's 2010 Fiesta 1.4 had similar problems. Check the plug leads for corrosion and when were the spark plugs last replaced?

Return to General Ford Tech Talk

Who is online

Users browsing this forum: No registered users and 1 guest